summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2020-02-22 13:20:31 +0100
committerLars-Dominik Braun <lars@6xq.net>2020-02-22 13:23:26 +0100
commit0f8643954fd9507aec85bab46046e71a497bfffe (patch)
tree28708a991bd136fd255282326e93f7588120a2e3 /setup.py
parenta91fc5e945b841ae54f67ed331409ad857178f13 (diff)
downloadlulua-0f8643954fd9507aec85bab46046e71a497bfffe.tar.gz
lulua-0f8643954fd9507aec85bab46046e71a497bfffe.tar.bz2
lulua-0f8643954fd9507aec85bab46046e71a497bfffe.zip
doc: Switch to jinja2-based rendering
Pre-rendering HTML was not the best idea. Instead pre-process the data, cache it into data files and do the HTML rendering only as the final step. Also adds asymmetry to analysis and uses tabular numbers and spaces instead of ugly table hacks to align numbers.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2e20067..4134766 100644
--- a/setup.py
+++ b/setup.py
@@ -25,7 +25,7 @@ setup(
version='0.1dev0',
author='Lars-Dominik Braun',
author_email='lars+lulua@6xq.net',
- #url='https://6xq.net/crocoite/',
+ url='https://6xq.net/lulua/',
packages=['lulua'],
license='LICENSE.txt',
description='Keyboard layout optimization',
@@ -39,16 +39,22 @@ setup(
'tqdm',
'html5lib',
'ebooklib',
+ 'jinja2',
],
entry_points={
'console_scripts': [
'lulua-analyze = lulua.stats:main',
'lulua-render = lulua.render:render',
+ 'lulua-report = lulua.report:render',
'lulua-import = lulua.layout:importFrom',
'lulua-optimize = lulua.optimize:optimize',
'lulua-write = lulua.text:write',
],
},
+ package_data = {
+ 'lulua': ['data/*', 'data/keyboards/*.yaml', 'data/layouts/*.yaml',
+ 'data/report/*', 'data/winkbd/*'],
+ },
setup_requires=['pytest-runner'],
tests_require=["pytest", 'pytest-cov'],
python_requires='>=3.6',