summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2019-09-17 18:31:24 +0200
committerLars-Dominik Braun <lars@6xq.net>2019-09-17 18:31:24 +0200
commit969d1d393e75a229523c234203059fb570d28ed1 (patch)
tree5e11a08af59309b8245b3c3d062de639a7d30350 /setup.py
downloadlulua-969d1d393e75a229523c234203059fb570d28ed1.tar.gz
lulua-969d1d393e75a229523c234203059fb570d28ed1.tar.bz2
lulua-969d1d393e75a229523c234203059fb570d28ed1.zip
Initial import
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py56
1 files changed, 56 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..f0c3d2d
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,56 @@
+# Copyright (c) 2019 lulua contributors
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+# THE SOFTWARE.
+
+from setuptools import setup
+
+setup(
+ name='lulua',
+ version='0.1dev0',
+ author='Lars-Dominik Braun',
+ author_email='lars+lulua@6xq.net',
+ #url='https://6xq.net/crocoite/',
+ packages=['lulua'],
+ license='LICENSE.txt',
+ description='The monkey.',
+ long_description=open('README.rst').read(),
+ long_description_content_type='text/x-rst',
+ install_requires=[
+ 'pygtrie',
+ 'pyyaml',
+ 'svgwrite',
+ 'bokeh',
+ 'tqdm',
+ 'html5lib',
+ ],
+ entry_points={
+ 'console_scripts': [
+ 'lulua-combine-stats = lulua.stats:combine',
+ 'lulua-pretty-stats = lulua.stats:pretty',
+ 'lulua-render = lulua.render:render',
+ 'lulua-import-klc = lulua.model:importKlc',
+ 'lulua-plot = lulua.plot:plot',
+ 'lulua-optimize = lulua.optimize:optimize',
+ 'lulua-write = lulua.text:write',
+ ],
+ },
+ setup_requires=['pytest-runner'],
+ tests_require=["pytest", 'pytest-cov'],
+ python_requires='>=3.6',
+)