aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorgermeier <germeier>2005-04-20 17:36:02 +0000
committergermeier <germeier>2005-04-20 17:36:02 +0000
commitc0ea430685dd51167ef179fb7f6d7878f5bc56af (patch)
tree6353100243d3a21e9c26d11ae1ae1d4bf8f2d926 /configure.in
parent02dec855fa9917459c6ecf25ec2c6b10d76f9d7a (diff)
downloadmpiosh-c0ea430685dd51167ef179fb7f6d7878f5bc56af.tar.gz
mpiosh-c0ea430685dd51167ef179fb7f6d7878f5bc56af.tar.bz2
mpiosh-c0ea430685dd51167ef179fb7f6d7878f5bc56af.zip
fixed version check for libusb, use black list instead
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index c52f76a..eb61c9e 100644
--- a/configure.in
+++ b/configure.in
@@ -78,16 +78,17 @@ if test -n "${LIBUSB_CONFIG}"; then
CPPFLAGS="$CPPFLAGS_save"
fi
- # This 'test' call uses non-standard syntax and will fail on most
- # systems, but it's just informational so any warning can be ignored.
-if test "$LIBUSB_VER" \< "0.1.7"; then
+dnl --- blacklist the too old versions
+case "$LIBUSB_VER" in
+ 0.1.[[0123456]]|0.1.[[36]][[ab]])
AC_MSG_WARN([
*** You need at least version 0.1.7 of the libusb library for USB support
*** http://sourceforge.net/projects/libusb/
*** If you cannot find the appropriate version, try CVS
])
- exit 1
-fi
+ exit 1 ;;
+ *);;
+esac
case "$usb_msg" in
yes*) AC_DEFINE(HAVE_USB,1,[Whether you have USB support enabled]);;