summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2019-07-04 21:11:51 +0200
committerLars-Dominik Braun <lars@6xq.net>2019-07-04 21:11:51 +0200
commit71af236effa3acd32a7825b0f55146d6180c5e18 (patch)
treec4f04acc296eb0eaa3b92832c580dbf37c78cf0a /setup.py
parent8a6b92575a7d2ef088ee2c9081ed418641cfc126 (diff)
downloadcrocoite-71af236effa3acd32a7825b0f55146d6180c5e18.tar.gz
crocoite-71af236effa3acd32a7825b0f55146d6180c5e18.tar.bz2
crocoite-71af236effa3acd32a7825b0f55146d6180c5e18.zip
Release version 1.0.0v1.0.0
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 11 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0baf768..28d8069 100644
--- a/setup.py
+++ b/setup.py
@@ -2,13 +2,15 @@ from setuptools import setup
setup(
name='crocoite',
- version='0.1.0',
+ version='1.0.0',
author='Lars-Dominik Braun',
author_email='lars+crocoite@6xq.net',
+ url='https://6xq.net/crocoite/',
packages=['crocoite'],
license='LICENSE.txt',
description='Save website to WARC using Google Chrome.',
long_description=open('README.rst').read(),
+ long_description_content_type='text/x-rst',
install_requires=[
'warcio',
'html5lib>=0.999999999',
@@ -44,4 +46,12 @@ setup(
setup_requires=['pytest-runner'],
tests_require=["pytest", 'pytest-asyncio', 'pytest-cov', 'hypothesis'],
python_requires='>=3.6',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'License :: OSI Approved :: MIT License',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Topic :: Internet :: WWW/HTTP',
+ ],
)