summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2017-12-10 12:31:07 +0100
committerLars-Dominik Braun <lars@6xq.net>2017-12-17 16:40:16 +0100
commit84c3f69293fa79d752127410c7468038c907c96a (patch)
tree4a71dcddd6abc6eeda30ed40bd78d91518efde38 /setup.py
parentf816319081d5253974ddb70b655d55f4a880a77a (diff)
downloadcrocoite-84c3f69293fa79d752127410c7468038c907c96a.tar.gz
crocoite-84c3f69293fa79d752127410c7468038c907c96a.tar.bz2
crocoite-84c3f69293fa79d752127410c7468038c907c96a.zip
Add distributed archiving
Using celery. Also adds a plugin for the IRC bot sopel. Code still needs some love, but it should work.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 52747c0..0ab9249 100644
--- a/setup.py
+++ b/setup.py
@@ -13,13 +13,14 @@ setup(
'pychrome',
'warcio',
'html5lib>=0.999999999',
+ 'Celery',
],
entry_points={
'console_scripts': [
'crocoite-standalone = crocoite.cli:main',
],
},
- data_files=[
- ('crocoite/data', ['crocoite/data/onload.js']),
- ],
+ package_data={
+ 'crocoite': ['data/*'],
+ },
)