summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2018-10-14 12:41:37 +0200
committerLars-Dominik Braun <lars@6xq.net>2018-10-14 12:43:39 +0200
commit958563a3602780b48599c27acf212139c2e6904d (patch)
treebc3b3e1209691c320122b4586972e275563cc867 /setup.py
parent07994fb6b72b0c84d2ee2c69e5afdb204d33d5e6 (diff)
downloadcrocoite-958563a3602780b48599c27acf212139c2e6904d.tar.gz
crocoite-958563a3602780b48599c27acf212139c2e6904d.tar.bz2
crocoite-958563a3602780b48599c27acf212139c2e6904d.zip
irc: Add PoC dashboard
Using websockets, vue and bulma.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 0ca55f8..0debaf4 100644
--- a/setup.py
+++ b/setup.py
@@ -15,12 +15,14 @@ setup(
'html5lib>=0.999999999',
'bottom',
'pytz',
+ 'websockets',
],
entry_points={
'console_scripts': [
'crocoite-grab = crocoite.cli:single',
'crocoite-recursive = crocoite.cli:recursive',
'crocoite-irc = crocoite.cli:irc',
+ 'crocoite-irc-dashboard = crocoite.cli:dashboard',
'crocoite-merge-warc = crocoite.tools:mergeWarc',
'crocoite-extract-screenshot = crocoite.tools:extractScreenshot',
],