summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py31
1 files changed, 26 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 5ae7e65..628442e 100644
--- a/setup.py
+++ b/setup.py
@@ -2,13 +2,15 @@ from setuptools import setup
setup(
name='crocoite',
- version='0.1.0',
+ version='1.1.1',
author='Lars-Dominik Braun',
author_email='lars+crocoite@6xq.net',
+ url='https://6xq.net/crocoite/',
packages=['crocoite'],
license='LICENSE.txt',
description='Save website to WARC using Google Chrome.',
long_description=open('README.rst').read(),
+ long_description_content_type='text/x-rst',
install_requires=[
'warcio',
'html5lib>=0.999999999',
@@ -17,20 +19,39 @@ setup(
'websockets',
'aiohttp',
'PyYAML',
+ 'yarl>=1.4,<1.5',
+ 'multidict',
],
+ extras_require={
+ 'manhole': ['manhole>=1.6'],
+ },
entry_points={
'console_scripts': [
- 'crocoite-grab = crocoite.cli:single',
- 'crocoite-recursive = crocoite.cli:recursive',
+ # the main executable
+ 'crocoite = crocoite.cli:recursive',
+ # backend helper
+ 'crocoite-single = crocoite.cli:single',
+ # irc bot and dashboard
'crocoite-irc = crocoite.cli:irc',
'crocoite-irc-dashboard = crocoite.cli:dashboard',
+ # misc tools
'crocoite-merge-warc = crocoite.tools:mergeWarcCli',
'crocoite-extract-screenshot = crocoite.tools:extractScreenshot',
+ 'crocoite-errata = crocoite.tools:errata',
],
},
package_data={
'crocoite': ['data/*'],
},
- setup_requires=["pytest-runner"],
- tests_require=["pytest", 'pytest-asyncio', 'pytest-cov'],
+ setup_requires=['pytest-runner'],
+ tests_require=["pytest", 'pytest-asyncio', 'pytest-cov', 'hypothesis'],
+ python_requires='>=3.6',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'License :: OSI Approved :: MIT License',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Topic :: Internet :: WWW/HTTP',
+ ],
)