summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..fbada48
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,30 @@
+# Always prefer setuptools over distutils
+from setuptools import setup, find_packages
+# To use a consistent encoding
+from codecs import open
+from os import path
+
+here = path.abspath(path.dirname(__file__))
+
+# Get the long description from the README file
+with open(path.join(here, 'README.rst'), encoding='utf-8') as f:
+ long_description = f.read()
+
+setup(
+ name='ilpscheduling',
+ version='0.1',
+ description='ILP scheduling using gurobipy',
+ long_description=long_description,
+ #url='https://github.com/pypa/sampleproject',
+ # Author details
+ author='Lars-Dominik Braun',
+ author_email='lars@6xq.net',
+ license='MIT',
+ packages=find_packages(exclude=['contrib', 'docs', 'tests']),
+ #install_requires=['gurobipy'],
+ entry_points={
+ 'console_scripts': [
+ 'ilpsched=ilpscheduling:main',
+ ],
+ },
+)