aboutsummaryrefslogtreecommitdiff
path: root/mpiosh/CMakeLists.txt
diff options
context:
space:
mode:
authorLars-Dominik Braun <PromyLOPh@lavabit.com>2009-05-09 13:08:34 +0200
committerLars-Dominik Braun <PromyLOPh@lavabit.com>2009-05-09 13:08:34 +0200
commit454110e1b17214b220317704f092bd3587b88a9d (patch)
tree493652e227af43167749192692f6725bbc6392e5 /mpiosh/CMakeLists.txt
parentf442b22fd6182b7d6707f90a558cd358f269dd1d (diff)
downloadmpiosh-454110e1b17214b220317704f092bd3587b88a9d.tar.gz
mpiosh-454110e1b17214b220317704f092bd3587b88a9d.tar.bz2
mpiosh-454110e1b17214b220317704f092bd3587b88a9d.zip
Switch to cmake
"Works for now..."
Diffstat (limited to 'mpiosh/CMakeLists.txt')
-rw-r--r--mpiosh/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/mpiosh/CMakeLists.txt b/mpiosh/CMakeLists.txt
new file mode 100644
index 0000000..efff2c7
--- /dev/null
+++ b/mpiosh/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required (VERSION 2.4)
+
+set (PACKAGE mpiosh)
+project (${PACKAGE} C)
+
+set (CMAKE_C_FLAGS -Wall)
+
+configure_file (${CMAKE_CURRENT_SOURCE_DIR}/config.h.in
+ ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+
+include_directories (${CMAKE_CURRENT_SOURCE_DIR}/..)
+
+add_executable (mpiosh mpiosh.c callback.c readline.c command.c global.c
+ cfgio.c cfg.c)
+target_link_libraries (mpiosh mpio -lreadline -lncurses)