aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in46
1 files changed, 46 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..8dd366b
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,46 @@
+dnl -*- shell-script -*-
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(kernel/mpio.c)
+dnl AM_CONFIG_HEADER(src/config.h)
+
+AC_CANONICAL_SYSTEM()
+AC_MSG_RESULT(Building for a ${host} host.)
+
+AM_INIT_AUTOMAKE(mpio, 0.0.1)
+
+dnl Checks for programs.
+
+AC_PROG_MAKE_SET
+AC_PROG_CC
+AM_PROG_LIBTOOL
+
+dnl check for kernel version
+kernel_version=`uname -r 2>&1`
+echo -n "checking for kernel version ... "
+case "$kernel_version" in
+ '') kernel_version="?.??"; _k_verc_fail=yes;;
+ [0-1].[0-9].[0-9]*|2.[0-1].[0-9]*)
+ _k_verc_fail=no;;
+esac
+echo $kernel_version
+if test "$_k_verc_fail" ; then
+ echo " Your kernel version is to old."
+ echo " Please update your system to a kernel version of 2.2.x or higher."
+fi
+
+dnl Checks for header files.
+
+AC_CHECK_HEADER(getopt.h,HAVE_GETOPT_H=1,HAVE_GETOPT_H=0)
+AC_SUBST(HAVE_GETOPT_H)
+
+dnl ------------------------------------------------------------
+
+# could not find a way to compile the kernel module correctly
+# kernel/Makefile
+AC_OUTPUT(
+ Makefile
+ kernel/Makefile
+ libmpio/Makefile
+ mpio_tool/Makefile )
+
+