aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/README6
-rw-r--r--debian/changelog5
-rw-r--r--debian/control21
-rw-r--r--debian/copyright26
-rw-r--r--debian/docs5
-rw-r--r--debian/libmpio-dev.install1
-rw-r--r--debian/libmpio.install2
-rw-r--r--debian/mpio-tools.install3
-rw-r--r--debian/postinst42
-rwxr-xr-xdebian/rules9
10 files changed, 120 insertions, 0 deletions
diff --git a/debian/README b/debian/README
new file mode 100644
index 0000000..e04899b
--- /dev/null
+++ b/debian/README
@@ -0,0 +1,6 @@
+The Debian Package mpio
+----------------------------
+
+Comments regarding the Package
+
+Andreas Büsching <crunchy@bitkipper.net>, Sat, 1 Apr 2006 19:40:10 +0200
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..da87b83
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+mpio (0.7.1-1) unstable; urgency=low
+
+ * Initial Release.
+
+ -- Andreas Büsching <crunchy@bitkipper.net> Mon, 3 Apr 2006 23:15:38 +0200
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..1dfcd1c
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,21 @@
+Source: mpio
+Section: misc
+Priority: optional
+Maintainer: Andreas Büsching <crunchy@bitkipper.net>
+Build-Depends: debhelper (>= 4.0.0), autotools-dev, cdbs, libusb-dev, libreadline5-dev
+Standards-Version: 3.6.2
+
+Package: libmpio
+Architecture: any
+Depends: ${shlibs:Depends}, libusb-0.1-4
+Description: provides access to MPIO MP3 players
+
+Package: libmpio-dev
+Architecture: all
+Depends: ${shlibs:Depends}
+Description: Development files for the MPIO library
+
+Package: mpio-tools
+Architecture: any
+Depends: ${shlibs:Depends}, libmpio, libreadline5
+Description: MPIO Shell and MPIO Logo
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..e98c416
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,26 @@
+This is gex, written and maintained by unknown <crunchy@bitkipper.net>
+on Sat, 1 Apr 2006 19:40:10 +0200.
+
+The original source can always be found at:
+ ftp://ftp.debian.org/dists/unstable/main/source/
+
+Copyright (C) 2005 unknown
+
+License:
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..ed91ff0
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,5 @@
+NEWS
+README
+TODO
+COPYING
+AUTHORS
diff --git a/debian/libmpio-dev.install b/debian/libmpio-dev.install
new file mode 100644
index 0000000..f616c9a
--- /dev/null
+++ b/debian/libmpio-dev.install
@@ -0,0 +1 @@
+debian/tmp/usr/include/mpio/*
diff --git a/debian/libmpio.install b/debian/libmpio.install
new file mode 100644
index 0000000..dd9256f
--- /dev/null
+++ b/debian/libmpio.install
@@ -0,0 +1,2 @@
+debian/tmp/usr/lib/libmpio*
+debian/tmp/etc/hotplug/usb/*
diff --git a/debian/mpio-tools.install b/debian/mpio-tools.install
new file mode 100644
index 0000000..38676ab
--- /dev/null
+++ b/debian/mpio-tools.install
@@ -0,0 +1,3 @@
+debian/tmp/usr/bin/*
+debian/tmp/etc/mpio/*
+
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..7f8c955
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,42 @@
+#! /bin/sh
+# postinst script for gex
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+#
+
+case "$1" in
+ configure)
+
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..3ef0c01
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,9 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+
+install/libgmbus-doc::
+ mkdir -p debian/tmp/usr/share/doc/mpio/