summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index faac129..9dbd6f2 100644
--- a/configure.in
+++ b/configure.in
@@ -7,8 +7,6 @@ AC_ARG_ENABLE(pthread, [ --enable-pthread compile FLAM3 with threads ena
AC_ARG_ENABLE(atomic_ops, [ --enable-atomic-ops compile FLAM3 with atom ops enabled (default=yes, independently checks for 32 and 64 bit sizes)])
AM_INIT_AUTOMAKE(flam3,"3.0.1")
-AC_CONFIG_MACRO_DIR([m4])
-
# Save CFLAGS from the environment
save_CFLAGS=$CFLAGS
@@ -36,9 +34,9 @@ fi
if test "${enable_atomic_ops}" = "yes" ; then
AC_MSG_CHECKING([whether $CC knows 32-bit __sync_bool_compare_and_swap()])
- AC_LANG_CONFTEST([#include <stdint.h>
+ AC_LANG_CONFTEST([AC_LANG_SOURCE([[#include <stdint.h>
int main() { uint32_t a = 4;
- __sync_bool_compare_and_swap(&a, 4, 5); }])
+ __sync_bool_compare_and_swap(&a, 4, 5); }]])])
$CC conftest.c $CFLAGS -o conftest > /dev/null 2> /dev/null
ret=$?
rm -f conftest.o conftest
@@ -50,8 +48,8 @@ if test "${enable_atomic_ops}" = "yes" ; then
fi
AC_MSG_CHECKING([whether $CC knows 64-bit __sync_bool_compare_and_swap()])
- AC_LANG_CONFTEST([#include <stdint.h>
- int main() { uint64_t a = 4; __sync_bool_compare_and_swap(&a, 4, 5); }])
+ AC_LANG_CONFTEST([AC_LANG_SOURCE([[#include <stdint.h>
+ int main() { uint64_t a = 4; __sync_bool_compare_and_swap(&a, 4, 5); }]])])
$CC conftest.c $CFLAGS -o conftest > /dev/null 2> /dev/null
ret=$?
rm -f conftest.o conftest