summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2019-01-27 11:49:17 +0100
committerLars-Dominik Braun <lars@6xq.net>2019-01-27 11:49:17 +0100
commit184189f0a535996edca01a68182ed07d32e26e9c (patch)
tree953181e7e62195476ef0dfcf4cb5e77160c664d1 /setup.py
parent0af80da0b506a06593c81d3686e91b8b82a4f3ba (diff)
downloadcrocoite-184189f0a535996edca01a68182ed07d32e26e9c.tar.gz
crocoite-184189f0a535996edca01a68182ed07d32e26e9c.tar.bz2
crocoite-184189f0a535996edca01a68182ed07d32e26e9c.zip
Support manhole debugging
Add optional support for manhole to all cli tools. Activated by signal USR1.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7cf6b32..7344470 100644
--- a/setup.py
+++ b/setup.py
@@ -20,6 +20,9 @@ setup(
'yarl',
'multidict',
],
+ extras_require={
+ 'manhole': ['manhole>=1.6'],
+ },
entry_points={
'console_scripts': [
'crocoite-grab = crocoite.cli:single',