summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2018-12-25 18:56:55 +0100
committerLars-Dominik Braun <lars@6xq.net>2018-12-25 18:59:55 +0100
commitcc1132a5b4677d089e024bcd0e16e1e817a3581c (patch)
tree8509c3cca27c8c7a2620093f03a3fb4e3bb7e45b /setup.py
parentf8217408eeea5531b5f4f353b238dc94de705132 (diff)
downloadcrocoite-cc1132a5b4677d089e024bcd0e16e1e817a3581c.tar.gz
crocoite-cc1132a5b4677d089e024bcd0e16e1e817a3581c.tar.bz2
crocoite-cc1132a5b4677d089e024bcd0e16e1e817a3581c.zip
warc: Add tests
Using hyothesis-based testcase generation. This is quite nice compared to manual test data generation, since it catches alot more corner cases (if done right). This commit also fixes a few issues, including: - log records will only be written if the log is nonempty - properly quote packageUrl path’s - drop old thread checking code - use placeholder url for scripts without name
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0a21c02..982fa92 100644
--- a/setup.py
+++ b/setup.py
@@ -34,5 +34,5 @@ setup(
'crocoite': ['data/*'],
},
setup_requires=["pytest-runner"],
- tests_require=["pytest", 'pytest-asyncio', 'pytest-cov'],
+ tests_require=["pytest", 'pytest-asyncio', 'pytest-cov', 'hypothesis'],
)